FAQ answer

What kind of software do I need to participate in your courses?

You only need a modern browser such as Netscape 7 or above; Safari 2.0 or above, Firefox 1.5 or above. While the Moodle displays work most of the time with Internet Explorer 6, there is a known problem in Microsoft's implementation that prevents IE from working with our AJAX-based chat program. If you have only IE installed, we require that you install FireFox for access to chat. You may download FireFox for free from the Mozilla support site.

Scholars Online is accredited by AdvancED and the Northwest Accreditation Commission.